Forum Archive        Main Page EOLC
EOLC Forum » Core.ini settings  
   
 
Autor
Beitrag [  1  2    »  ]
Stefan Pfeifer




Dabei seit: September 2000
Herkunft: Göttingen, Germany
3069 Beiträge
Core.ini settings 

Bitte überprüft mal alle eure core.ini-Datei. Möglicherweise nutzen einige von euch Einstellungen, die die Warps verursachen. Die Werte auf dem Server sehen so aus:

[ Communications ]
alternate_ip_addr_lookup = 1 ; Find IP addresses another way
bcast_augment_status = 0 ; Prepend status with IP address?
bcast_listserv = ; IP address of race list server
;bcast_listserv_req = ; Empty string, or start with '?'
;bcast_listserv_req_freq = 10.000000 ; Request race list frequency
bcast_ping_disable = 0 ; Disable response to pings
bcast_ping_port = 0 ; Ping port number (0=default)
bcast_port = 0 ; Broadcast port number (0=default)
;bcast_recv_disable = 0 ; Disable broadcast reception
bcast_send_disable = 1 ; Disable sending broadcasts
bcast_send_freq = 40 ; Broadcast frequency (seconds)
;clock_adj_delay = 4 ; How often may client adjust clock?
disable_ipx = 1 ; Disable IPX support
disable_modem = 1 ; Don't look for/use modems
disable_network = 1 ; Disable network support
disable_tcp_ip = 0 ; Disable TCP/IP support
ignore_net_read_errors = 1 ; Don't disco if error reading pkt
ignore_net_send_errors = 1 ; Don't disco if error sending pkt
;ip_addr_lookup_timeout = 2 ; Timeout to find own IP address
log_server_comm_errors = 0 ; Log errors for client channels?
log_server_connect_status = 0 ; Issue messages as clients connect
;mem_client_send_every = 1 ; Client packet freq via memory
;mem_client_send_size = 276 ; Client packet size via memory
;mem_server_send_every = 1 ; Server packet freq via memory
;mem_server_send_size = 516 ; Server packet size via memory
net_lan_client_send_every = 3 ; Client packet freq on LAN
net_lan_client_send_size = 84 ; Client packet size on LAN
net_lan_server_send_every = 3 ; Server packet freq on LAN
net_lan_server_send_size = 84 ; Server packet size on LAN
net_mdm_client_send_every = 3 ; Client packet freq on dialup
net_mdm_client_send_size = 84 ; Client packet size on dialup
net_mdm_server_send_every = 3 ; Server packet freq on dialup
net_mdm_server_send_size = 132 ; Server packet size on dialup
net_server_port = 0 ; Server port number (0 = default)
net_use_mdm_bandwidth_for_tcp_ip = 1 ; Use modem bandwidthfor TCP/IP


Wenn eure Werte abweichen macht euch eine Kopie von der alten Datei (schadet nie) und kopiert den kompletten [communications]-Abschnitt in eure Datei. Die Werte oben funktionieren bei Netzwerkverbindungen, bei anderen Verbindungen weiß ich nicht, was passiert.

Gruß - Stefan


*************************************************************

Please check your core.ini settings. Maybe some people use settings that cause warping. Compare your settings with the settings from the EOLC server given above.

If your settings are different backup your core.ini and replace your [communications]-section with the values above. It will work fine with a network connection, i don't know if it will help with different connections.

Regards, Stefan

01.08.2008, 10:42  
Kelvin Mace




Dabei seit: Juli 2007
Herkunft: Bayern
825 Beiträge
   

Ja wie sieht das denn bei mir aus ??

[Communications]
alternate_ip_addr_lookup = 1
net_use_mdm_bandwidth_for_tcp_ip = 1
net_mdm_client_send_size = 84
net_mdm_server_send_size = 384
net_mdm_client_send_every = 3
net_mdm_server_send_every = 3

Sind meine Einstellungen mit denen ich seit je her gefahren bin nun völlig falsch?

Grüsse Kelvin , jetzt bin ich echt verwirrt

01.08.2008, 11:25  
Karl-Jürgen Hilger




Dabei seit: Juli 2006
Herkunft: Hamburg
1835 Beiträge
   

Nein, das ist alles ok.
Stefans Server ist mit dem Bandwidth-Patch darauf ausgelegt, 8 Autos in Deinem Fahrumfeld zu zeigen.
(net_mdm_server_send_size = 132)

Dein Eintrag
(net_mdm_server_send_size = 384)
geht von 19 Autos aus.

Da dies aber nie passiert, sollte sich bei Dir diesbezüglich auch nie die Frage einer Überlastung stellen.

Nachzulesen in den readmes zum Bandwidth-Patch, die ich bei eigener Servererstellung durchkauen musste.

Korrigier mich, wenn nötig, Stefan.

Gruss
KJ

01.08.2008, 13:41  
Stefan Pfeifer




Dabei seit: September 2000
Herkunft: Göttingen, Germany
3069 Beiträge
   

Mit den Parametern habe ich mich nie beschäftigt, die core.ini ist weitgehend geerbt und stammt bis auf die Einträge vom BW-Patch von Hanspi's SRCB-Server. Alles mit";" davor ist auskommentiert und wird nicht benutzt. Die Einträge mit bcast_ und log_ sind wahrscheinlich nur auf dem Server nötig. Auf meinem GPL-Rechner funktioniert es mit diesen Werten tadellos.

Wer eine stabile Verbindung hat muss seine Einträge nicht unbedingt ändern. Wer Probleme hat sollte sie auf jeden Fall ausprobieren .

Gruß - Stefan

01.08.2008, 13:56  
Carsten Theile




Dabei seit: Februar 2006
Herkunft: Dresden
3884 Beiträge
   

Hallo,

die Einstellungen, die sich auch in meiner Core.ini wiederfinden, stimmen überein. Doch der Communications-Abschnitt ist bei weitem nicht so lang wie der in der Ini des Servers...

code:
[ Communications ]
disable_network = 0
alternate_ip_addr_lookup = 1
disable_ipx = 1
disable_modem = 1 ; If you use a modem change to 0!
net_mdm_client_send_every = 3
net_mdm_client_send_size = 84
net_mdm_server_send_every = 3
net_mdm_server_send_size = 384 ; show 19 cars
net_use_mdm_bandwidth_for_tcp_ip = 1


Das ist der gesamte Communications-Abschnitt. Braucht man als Client mehr Einstellungen als diese? Gut, die folgenden zwei Settings halte ich noch für wichtig:

In VROC hab ich im Join-Fenster unter "Advanced" noch "ignore net READ errors" und "ignore net SEND errors" aktiviert, was sich auch in Stefans core.ini wiederfindet:
code:
ignore_net_read_errors = 1 ; Don't disco if error reading pkt
ignore_net_send_errors = 1 ; Don't disco if error sending pkt

Hier also kein Problem. Die Aussage "Don't disco if ..." klingt ja auch schaurig...

Jetzt zurück zu meiner Frage: Welche Settings sind für den Client noch relevant? Broadcast und log_server_ sind serverseitig, net_lan_ braucht man als Internetfahrer nicht.
Bleibt eigentlich nur "disable_tcp_ip = ", was relevant wäre, aber nicht in meiner Core.ini steht. Wenn es nicht drinsteht, ist es dann standardmäßig enabled oder standardmäßig disabled? Wahrscheinlich spielt das keine Rolle, aber interessant zu wissen wäre es doch
EDIT: Dort muss ja 'ne Null stehen, sonst könnte ich ja net fahren Richtig?

Gruß
die verwirrte Katze

01.08.2008, 17:10  
Karl-Jürgen Hilger




Dabei seit: Juli 2006
Herkunft: Hamburg
1835 Beiträge
   

Richtig, Cat!

Wichtig scheint mir noch folgender Eintrag zu sein:

[ Task ]
synch_method = 1 ; Client synch method

Das beeinflußt den bei Stefan deaktivierten Parameter

;clock_adj_delay = 4 ; How often may client adjust clock?

Man sollte sicher stellen, dass "synch_method = 1" standardmäßig da steht. Nur dann wird
clock_adj_delay = 4
ebenfalls als Standard aktiv.

Da ich davon ausgehe, dass auch Stefan
"synch_method = 1" hat, sollte man dies kurz kontrollieren.



Edit: Beispiel
Ich habe nämlich
clock_adj_delay = 8
in der ini stehen.

Aber synch_method = 1 reguliert das dann auf den Wert 4

Die 8 würde erst aktiv bei synch_method = 0

Edit2:
Die Werte betreffen zwar beide nur den Clienten, aber wer weiss, wie der Server darüber denkt, wenn er mit verschiedenen Synchronisations-Methoden angefunkt wird...


Gruss
KJ

01.08.2008, 18:13  
Carsten Theile




Dabei seit: Februar 2006
Herkunft: Dresden
3884 Beiträge
   

Hm, ich arbeite dann doch lieber mittels GUI VROC bietet noch die Option, die alte Synchronisationsmethode zu nutzen. Das hab ich aus. Welche Einstellung bedeutet das jetzt in der Ini? Bedeutet das dann "synch_method = 1"? Sprich 0=alte Synchonisationsmethode und 1=neue Synchonisationsmethode?

Gruß
Carsten

01.08.2008, 19:06  
Karl-Jürgen Hilger




Dabei seit: Juli 2006
Herkunft: Hamburg
1835 Beiträge
   

Ja, das ist richtig.
1 ist neu und für GPL Clienten v1.1 und 1.2

01.08.2008, 19:14  
Carsten Theile




Dabei seit: Februar 2006
Herkunft: Dresden
3884 Beiträge
   

Hehe, sorry, dass ich solche dummen Fragen stell Steht sowas in einer Readme von Papyrus?
Hab in keiner was finden können...

Gruß
Carsten

01.08.2008, 19:27  
Karl-Jürgen Hilger




Dabei seit: Juli 2006
Herkunft: Hamburg
1835 Beiträge
   

Steht in meiner core.ini

01.08.2008, 19:31  
Carsten Theile




Dabei seit: Februar 2006
Herkunft: Dresden
3884 Beiträge
   

In meiner nicht

Miau,
de Gadse

01.08.2008, 19:33  
Olaf Lehmann




Dabei seit: September 2006
Herkunft: Lichtenstein
2167 Beiträge
   

Meine mich zu erinnern, dass es in einer ReadMe steht, Carsten.
Liesmich11

01.08.2008, 19:34  
Carsten Theile




Dabei seit: Februar 2006
Herkunft: Dresden
3884 Beiträge
   

LOL, in der Readme steht es wirklich... im Netz
In meiner Readme ist gerade dieser eine Absatz, um den es geht, irgendwie rausgekürzt...

Nun gut... Ich danke Euch beiden

Gruß
de Gadse

01.08.2008, 19:52  
Karl-Jürgen Hilger




Dabei seit: Juli 2006
Herkunft: Hamburg
1835 Beiträge
   

Ach so, jetzt versteh ich erst das mögliche Mißverständnis...
Carsten, das war keine Verarschung von mir. Es steht wirklich mit Erklärung in meiner core.ini.

KJ

01.08.2008, 20:02  
Carsten Theile




Dabei seit: Februar 2006
Herkunft: Dresden
3884 Beiträge
   

Da gab es kein Missverständnis. Meine Ini hat auch die ein oder andere Semikolon-Bemerkung, was den Bandwithpatch angeht. Nur es wir eben nicht alles erklärt. Ich hab wohl beim Installieren des BW-Patches einfach 'ne core.ini kopiert

Gruß
Carsten

01.08.2008, 22:31  
Matthias Weiner




Dabei seit: Oktober 2008
Herkunft:
26 Beiträge
   

Hi,

ich wollte heute abend in Glen vielleicht schonmal mein 1. Rennen mitfahren, aber kann leider auf die EOLC-Server nicht joinen. Hab die Einstellungen wie beschrieben in der core.ini abgeändert, aber ich bekomme immer noch: "Client/Server Bandwith Mismatch". Hat noch jemand eine Idee ?
VR-Server kann ich problemlos joinen.

11.11.2010, 18:01  
Olaf Lehmann




Dabei seit: September 2006
Herkunft: Lichtenstein
2167 Beiträge
   

Hmmm, merkwürdig.
Hab eben bei VR versucht. Ich komme dort hoch.
Hast Du mal "perHand" versucht?

IP Adresse siehe hier

11.11.2010, 18:06  
Jens Kraft




Dabei seit: August 2006
Herkunft:
4457 Beiträge
   

Zitat:
Original von Matthias Weiner
Hi,

ich wollte heute abend in Glen vielleicht schonmal mein 1. Rennen mitfahren, aber kann leider auf die EOLC-Server nicht joinen. Hab die Einstellungen wie beschrieben in der core.ini abgeändert, aber ich bekomme immer noch: "Client/Server Bandwith Mismatch". Hat noch jemand eine Idee ?
VR-Server kann ich problemlos joinen.




vergiss net die core ini settings auszuwählen!

11.11.2010, 18:26  
Matthias Weiner




Dabei seit: Oktober 2008
Herkunft:
26 Beiträge
   

das wars. Danke Jens !

11.11.2010, 19:37  
Jens Kraft




Dabei seit: August 2006
Herkunft:
4457 Beiträge
   

kein problem!

11.11.2010, 20:59  
   
   

Read-only archive of the EOLC forum powered by: Burning Board 1.1.1b © 2002 WoltLab GbR